$re = '/^[1-9][0-9]{1,8}\.?[0-9]{0,2}?$/m';
$str = '123456789.12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);