# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?P<ID>[A-Z0-9]{4})(?P<CATEGORY>0000[A-Z0-9]{1})(?P<TIMESTAMP>[0-9]{10})"
test_str = ("D812E66E0000A13297539619F990000A1326011227538F0000A134114416231680000A1333737336D7AB0000A1367834926D1A90000A1340522218B4D40000A1339938392DD4C0000A1346574058C1A20000A134475357330810000A136293851756F20000A1329934748A71A0000A1383377560B3F90000A13460667155BBE0000A1370955439BF490000A1336724039A6E90000A132550239864440000A13827086085A3F0000A1353692293BB7C0000A136799576755110000A1327676142DA5B0000A13536535381E270000A1332164993941B0000A133802356236AF0000A1345444250FBC50000A134544825251590000A1355240920\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.