package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi),\s(\S+)\s!|-\s(\S+)\sj`)
var str = `""" Yay you made it, User1 ! — 25/03/2022 --------------- User2 joined the party. — 22/03/2022 --------------- Yay you made it, User3 ! — 29/03/2022 --------------- User4 joined the party. — 28/03/2022"""`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}