using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?<!\d)-?\d+(?:\.\d+)?|[-+*/)(])";
string input = @"(5-10)
(5 + -10)
(-15 - 14)
(-25.5 * 2)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}