import re
regex = re.compile(r"^FIRST.*(?:\r?\n(?!SECOND\|[AB]\b).*)\r?\nSECOND\|B\b.*", flags=re.MULTILINE)
test_str = ("FIRST|[some text here] (newline)\n"
"[insert text here] (newline)\n"
"SECOND|A (newline)\n\n"
"FIRST|[some text here] (newline)\n"
"[insert text here] (newline)\n"
"SECOND|B (newline)\n\n"
"FIRST|[some text here] (newline)\n"
"[insert text here] (newline)\n"
"SECOND|A (newline)\n\n"
"FIRST|[some text here] (newline)\n"
"[insert text here] (newline)\n"
"SECOND|B (newline)\n\n"
"FIRST|[some text here] (newline)\n"
"[insert text here] (newline)\n"
"SECOND|A (newline)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")