$re = '/[^&0-9A-Za-z,.\' -]+/m';
$str = '*Bruce*-*Martha*-&-*Thomas%* *Wyane\'s* *Enterprises* ([#Pvt,Ltd.])';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;