import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=(?<!\\*)\\*\\*)\\w+(?=\\*\\*(?!\\*))|(?<=(?<!_)__)\\w+(?=__(?!_))";
final String string = "hello world **ant*** lorem **cat** opposum** *** ***antelope*** *rabbit __dog__";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}