$re = '/(?=[^\s]{0,2}D)(?=[^\s]{0,2}E).../m';
$str = 'DEA or ESD or DZE or PDE
DFA or ESC or VZE or DPe';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);