#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s)(\#\d{1,})(.*?)(?=(\#\d{1,}))"
Local $sString = "#0" & @CRLF & _
"$dumpvars" & @CRLF & _
"0!" & @CRLF & _
"0"" & @CRLF & _
"0#" & @CRLF & _
"bxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx 7" & @CRLF & _
"bxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx 6" & @CRLF & _
"bxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx 5" & @CRLF & _
"b0000000000000000 $" & @CRLF & _
"bxxxxxxxxxxxxxxxx /" & @CRLF & _
"bxxxxxxxxxxxxxxxx ." & @CRLF & _
"bxxxxxxxxxxxxxxxx )" & @CRLF & _
"b0111111111111111 %" & @CRLF & _
"bxxxxxxxxxxxxxxxx 1" & @CRLF & _
"bxxxxxxxxxxxxxxxx 0" & @CRLF & _
"bxxxxxxxxxxxxxxxx *" & @CRLF & _
"b10101010101010101010101010101010 &" & @CRLF & _
"bxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx +" & @CRLF & _
"bxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx ," & @CRLF & _
"bxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx 2" & @CRLF & _
"bxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx -" & @CRLF & _
"bxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx 3" & @CRLF & _
"bxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx 4" & @CRLF & _
"bxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx (" & @CRLF & _
"bxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx '" & @CRLF & _
"$end" & @CRLF & _
"#600" & @CRLF & _
"1!" & @CRLF & _
"b0000000000000000 )" & @CRLF & _
"b0111111111111111 *" & @CRLF & _
"b10101010101010101010101010101010 +" & @CRLF & _
"b0000000000000000 /" & @CRLF & _
"b0111111111111111 1" & @CRLF & _
"b00000000000000000000000000000000 5" & @CRLF & _
"b10101010101010101010101010101010 4" & @CRLF & _
"b00000000000000000000000000000000 2" & @CRLF & _
"b00000000000000000000000000000000 3" & @CRLF & _
"b010101010101010101010101010101010 7" & @CRLF & _
"#1200" & @CRLF & _
"b0000010001010111 $" & @CRLF & _
"b0111101110101000 %" & @CRLF & _
"b10101100101001110100001001010001 &" & @CRLF & _
"0!" & @CRLF & _
"b10101010101010101010101010101010 ," & @CRLF & _
"b00000000000000000000000000000000 -" & @CRLF & _
"#1800" & @CRLF & _
"1!" & @CRLF & _
"b0000010001010111 )" & @CRLF & _
"b0111101110101000 *" & @CRLF & _
"b10101100101001110100001001010001 +" & @CRLF & _
"b010101010101010101010101010101010 (" & @CRLF & _
"b010101010101010101010101010101010 '" & @CRLF & _
"b0000010001010111 /" & @CRLF & _
"b00000010001010110111101110101001 5" & @CRLF & _
"b0111101110101000 1" & @CRLF & _
"b00000010000110001010011000011000 5" & @CRLF & _
"b10101100101001110100001001010001 4" & @CRLF & _
"b010101100101001110100001001010001 7" & @CRLF & _
"b00000010000110001010011000011000 2" & @CRLF & _
"b00000010000110001010011000011000 3" & @CRLF & _
"b010101110101111111110100001101001 7" & @CRLF & _
"#2400" & @CRLF & _
"b0000100010101110 $" & @CRLF & _
"b0111011101010001 %" & @CRLF & _
"b10101110101000111101100111111000 &" & @CRLF & _
"0!" & @CRLF & _
"b10101100101001110100001001010001 ," & @CRLF & _
"b00000010000110001010011000011000 -" & @CRLF & _
"#3000" & @CRLF & _
"1!" & @CRLF & _
"b0000100010101110 )" & @CRLF & _
"b0111011101010001 *" & @CRLF & _
"b10101110101000111101100111111000 +" & @CRLF & _
"b010101110101111111110100001101001 (" & @CRLF & _
"b010101110101111111110100001101001 '" & @CRLF & _
"b0000100010101110 /" & @CRLF & _
"b00000100001100010100110000110000 5" & @CRLF & _
"b0111011101010001 1" & @CRLF & _
"b00000100000010111010000100001110 5" & @CRLF & _
"b10101110101000111101100111111000 4" & @CRLF & _
"b010110000101111001000000000010000 7" & @CRLF & _
"b00000100000010111010000100001110 2" & @CRLF & _
"b00000100000010111010000100001110 3" & @CRLF & _
"b010110010101011110111101100000110 7" & @CRLF & _
"#3600" & @CRLF & _
"b0000110100000101 $" & @CRLF & _
"b0111001011111010 %" & @CRLF & _
"b10110000101000000111000110011111 &" & @CRLF & _
"0!" & @CRLF & _
"b10101110101000111101100111111000 ," & @CRLF & _
"b00000100000010111010000100001110 -" & @CRLF & _
"#4200"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")