$re = '/(?<=username-)(\w+\.\w+).*?IP-((\d{1,3}\.){3}(\d{1,3}))/m';
$str = '03-25-2022 18:02:51 Local1.Notice 192.168.1.1 Mar 25 18:02:51 2022 192.168.1.1 stm[6358]: <501199> <NOTI> AP:AP01 <192.168.1.1 aa:bb:cc:dd:ee> User authenticated, mac-aa:bb:cc:dd:ee, username-my.username, IP-192.168.250.100, method-802.1x, role-blahblah';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);