using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(K((?!\/bc|\/a).)*?)(\d{4})";
string input = @"KYan this is /uaaaaaaaa 1987
KYan this is /azzzaaaaaaa 1987
KYan this is /bcaaaaaaa 1987
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}