$re = '/\d[^\/]*/m';
$str = 'Examplestreet 1/2.1/3a/10/10.1/11b/12a-12c/13a-c';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);