$re = '/^(source)+(?!.*external).*/m';
$str = 'abc.h
def.h
hij.h
external/test.h
external123/test.h
source/test.h
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);