import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^( \\d|\\d\\d) ";
final String string = " 1 (function(inDesignMode) {\n"
+ " 2 'use strict';\n"
+ " 3 ObjC.import('stdlib');\n"
+ " 4 \n"
+ " 5 function getPluginParameter(name) {\n"
+ " 6 var envName = \"KMPARAM_\" + name.replace(/ /g, \"_\");\n"
+ " 7 var result;\n"
+ " 8 \n"
+ " 9 if (!inDesignMode) {\n"
+ "10 result = $.getenv(envName);\n"
+ "11 return result ? result.trim() : \"\";\n"
+ "12 }\n"
+ "13 \n"
+ "14 var designingParams = {\n"
+ "15 KMPARAM_Sort_Order: \"newest first\",\n"
+ "16 KMPARAM_Timestamp_Format: \"date + time + duration\"\n"
+ "17 };\n"
+ "18 \n"
+ "19 result = designingParams[envName];\n"
+ "20 if (result === undefined)\n"
+ "21 throw Error(\"Unknown Plugin Parameter Name '\" + name + \"' while in designing mode\");\n"
+ "22 return result;\n"
+ "23 }\n"
+ "24 \n"
+ "25 function execute() {\n"
+ "26 var sortOrder = getPluginParameter(\"Sort Order\");\n"
+ "27 var timestampFormat = getPluginParameter(\"Timestamp Format\");\n"
+ "28 \n"
+ "29 return \"Sort Order: '\" + sortOrder + \"'\\nTimestamp Format: '\" + timestampFormat + \"'\";\n"
+ "30 }\n"
+ "31 \n"
+ "32 if (inDesignMode) {\n"
+ "33 return execute();\n"
+ "34 } else {\n"
+ "35 try {\n"
+ "36 return execute();\n"
+ "37 } catch (e) {\n"
+ "38 return e.message;\n"
+ "39 }\n"
+ "40 }\n"
+ "41 })(true);";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}