re = /(\b\w+\b)(?=.*\b\1\b)/m
str = 'Austria, "Belgium", "Bulgaria", "Czech Republic", "Cyprus", "Denmark", "Estonia", "Finland", "France", "Germany", Austria, "Greece", "Hungary", "Ireland", "Italy", "Latvia", "Lithuania", "Luxembourg", "Malta", "The Netherlands", "Poland", "Portugal", "Romania", "Slovenia", "Slovakia", "Spain", "Sweden", "United Kingdom", "Denmark", "Austria"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end