re = /(?<!=|^)(?=https?:\/\/)/m
str = 'http://foo.barhttps://foo.bazhttp://foo.bar?url=http://foo.baz'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end