re = /^(?=.*[A-Z].*[A-Z])(?=.*[!@#$&*])(?=.*[0-9].*[0-9])(?=.*[a-z].*[a-z].*[a-z]).{10,}$/m
str = 'Azb@Ag2!H3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end