$re = '`^(?:[A-Z]\w*\s[0-9]+\|)+$`m';
$str = 'Peter 50|Alex 20|
Peter 50|Alex|';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);