$re = '/Attributes: (?<Message>.+)/m';
$str = 'Reason: Details: Attributes: folderPathname folder ManagerDisplayName david foster OwnerEmail user@useremail';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);