import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-z][a-z0-9]{1,13}[_.\\-]?[a-z0-9]{1,13})@((([0-9]{1,3})([.]{1})([0-9]{1,3})([.]{1})([0-9]{1,3})([.]{1})([0-9]{1,3}))|([a-z0-9]{1,10}[\\-]?[a-z0-9]{1,10}[.]?[a-z0-9-]{1,10}[.]{1}[a-z]{2,4}))$";
final String string = "//Valid\n"
+ "john.doe@mail.com\n"
+ "johndoe@mail.com\n"
+ "john-doe@mail.com\n"
+ "john_doe@mail.com\n"
+ "john123doe@mail.com\n"
+ "john123.doe@mail.com\n"
+ "johndoe456@mail.com\n"
+ "abc-d@mail.com\n"
+ "test@test.domain.com\n"
+ "test@127.1.1.1\n"
+ "test@test.domain.shop\n\n"
+ "// Invalid\n"
+ "abc-@mail.com\n"
+ "abc..def@mail.com\n"
+ ".abc@mail.com\n"
+ "abc#def@mail.com\n"
+ "123abc-d@mail.com\n"
+ "ABc@mail.com\n"
+ "test@sub.test.domain.com\n"
+ "test@test.domain.c";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}