$re = '/^((0|00)?61[2-9]{1}\d{8})$/m';
$str = '61772369634';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);