import Foundation
let pattern = #"(Uni(t|ts)|Sho(p|ps)|Offic(e|es)|Fla(t|ts)?|Rm|Roo(m|ms)|Suit(e|es)).\w+(-|&)?\w*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
Rm. 2301, Blk. B3-B4,
Flat/Room 5, 9/F,
rm A, 17/F.,
Flat F, 9/F,
Flat G1, 10/F,
Flat C, 36/F, Block 1,
Flat 1107&1108, 11/F,
Flat 2301, 23/F, F
Unit 3, 2/F, L
Unit 1603 16/F
Offices D-F, 23/F,
Office D-F, 23/F,
Unit 1901, 19/F,
Units A, 6/F,
Shop 14, G/F,
Rooms 2202,
Suite 702, 7/F.,
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)