re = /^https:\/\/(?:www)?(?:\.?)website\.com$/m
str = 'https://website.com
https://www.website.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end