$re = '/[.0]+$/m';
$str = '21250000.022000
20.00
200
20.50
20
1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);