$re = '/^(\d)?\1*$/m';
$str = '5
5555
11111
22222
1234
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);