using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!""){{[^}{]+}}";
string input = @"Lorem ipsum {{ var }} dolar epsum <a href=""{{ var5 }}"">solar</a> hello goodbye. {{var3}} var {{ var2 }}
href=""{{ var }}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}