$re = '/^(?![0.]*$)\d{0,8}(?:\.\d{1,2})?$/m';
$str = '0000.00
00.00
0.0
100.00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);