package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^listings\/r\/([0-9]+)\/$`)
var str = `listings/r/3557653/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}