re = /(?<=mailfrom=)[^;]+(?=;)/
str = 'ezeze smtp.mailfrom=mymail@gmail.com; rerer'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end