# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:vessel|ETD)?[\s.:]?ETA[\s.:]{1,3}?(?:SIN)?[\s.:]?"
test_str = ("vessel eta: 12-10-19' should match with 'vessel eta: '\n"
"'vessel eta 12-10-19' should match with 'vessel eta '\n"
"'etd eta : 12/10/19' should match with 'etd eta '\n"
"'eta SIN: 12/10/19' should match with 'eta SIN:'\n"
"'eta : 12-10-19 should match with 'eta :'\n"
"'eta: 12-10-19' should match with 'eta: '\n"
"'eta. 12-10-19' should match with 'eta. '\n"
"'eta 12-10-19' should match with 'eta '")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.