const regex = /^https:\/\/vk\.com\/(?!album-?\d)[^\/]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https:\\\/\\\/vk\\.com\\\/(?!album-?\\d)[^\\\/]*$', 'gm')
const str = `https://vk.com/album9
https://vk.com/album123_456
https://vk.com/album-123
https://vk.com/a-tut_chot@@#\$%\$&-ugodno dazhe probely
Если пробелы запрещены, замените [^\\/]* на [^\\/\\s]*
^https:\\/\\/vk\\.com\\/(?!album\\d)[^\\/\\s]*\$`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}