$re = '/"(test)"\s*:\s*\K(?|"\K([^"]*)|\[\K([^]]*))/m';
$str = '"test":"value0"
"test":["value1", "value2"]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);