re = /(?<=Amount in Words:\n{2})(\S.+)/m
str = 'Amount in Words:
Five Hundred Ninety-nine only'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end