package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(.*[\\\/])`)
var str = `/webshop/product/Brabantia-6L-Sort--Go-Waste-Bin-Grey/342586011`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}