$re = '/\<ResponseID\>(?<ResponseID>[^\<]*)/m';
$str = 'message: <?xml version=\'1.0\' encoding=\'ISO-8859-1\'?><Submission Id="12345" <LastName>XXX</LastName><ResponseID>137ce83fe8ddb052-1698535326634</ResponseID><Date>2023.10.28 23:23:14</Date>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);