import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<!--od-(\\d+)--\\>(.*?)(?=<|$)";
final String string = "<!--od-1--> cdskc sdkjc \n"
+ "dsd\n"
+ "sk<!--od-2-->cscdscsdcsd \n"
+ "cdscs\n\n"
+ "csdcsdc\n"
+ "<!--od-432-->cdcdscsd";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}