package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(1\s?)?((\([0-9]{3}\))|[0-9]{3})[\s\-]?[\0-9]{3}[\s\-]?[0-9]{4}$`)
var str = `872-456-4532
(872) 456-4532
8724564532
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}