$re = '/(\w+:)*\'?(\w+)\'?/m';
$str = 'root:Folder1:fname
root:Folder1:\'name\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);