using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"devSummaryJson={.*(?=}]})";
string input = @"{""expand"": ""names,schema"",""startAt"": 0,""maxResults"": 50,""total"": 1,""issues"": [{""expand"": ""operations,versionedRepresentations,editmeta,changelog,renderedFields"",""id"": ""641955"",""self"": ""https://rb-tracker.bosch.com/tracker19/rest/api/latest/issue/641955"",""key"": ""EDATOOL-1411"",""fields"": {""created"": ""2022-12-06T11:14:36.000+0100"",""customfield_10000"": ""{summaryBean=com.atlassian.jira.plugin.devstatus.rest.SummaryBean@24a1688f[summary={pullrequest=com.atlassian.jira.plugin.devstatus.rest.SummaryItemBean@23f2f23c[overall=PullRequestOverallBean{stateCount=0, state='OPEN', details=PullRequestOverallDetails{openCount=0, mergedCount=0, declinedCount=0}},byInstanceType={}], build=com.atlassian.jira.plugin.devstatus.rest.SummaryItemBean@321de5ab[overall=com.atlassian.jira.plugin.devstatus.summary.beans.BuildOverallBean@6ca82c6[failedBuildCount=0,successfulBuildCount=0,unknownBuildCount=0,count=0,lastUpdated=<null>,lastUpdatedTimestamp=<null>],byInstanceType={}], review=com.atlassian.jira.plugin.devstatus.rest.SummaryItemBean@5fc3e1e6[overall=com.atlassian.jira.plugin.devstatus.summary.beans.ReviewsOverallBean@7a2d42e3[stateCount=0,state=<null>,dueDate=<null>,overDue=false,count=0,lastUpdated=<null>,lastUpdatedTimestamp=<null>],byInstanceType={}], deployment-environment=com.atlassian.jira.plugin.devstatus.rest.SummaryItemBean@2740d0b0[overall=com.atlassian.jira.plugin.devstatus.summary.beans.DeploymentOverallBean@75ceaa2c[topEnvironments=[],showProjects=false,successfulCount=0,count=0,lastUpdated=<null>,lastUpdatedTimestamp=<null>],byInstanceType={}], repository=com.atlassian.jira.plugin.devstatus.rest.SummaryItemBean@35c2a9a2[overall=com.atlassian.jira.plugin.devstatus.summary.beans.CommitOverallBean@2568cfa3[count=0,lastUpdated=<null>,lastUpdatedTimestamp=<null>],byInstanceType={}], branch=com.atlassian.jira.plugin.devstatus.rest.SummaryItemBean@40c4eee[overall=com.atlassian.jira.plugin.devstatus.summary.beans.BranchOverallBean@4131b89[count=0,lastUpdated=<null>,lastUpdatedTimestamp=<null>],byInstanceType={}]},errors=[],configErrors=[]], devSummaryJson={\""cachedValue\"":{\""errors\"":[],\""configErrors\"":[],\""summary\"":{\""pullrequest\"":{\""overall\"":{\""count\"":0,\""lastUpdated\"":null,\""stateCount\"":0,\""state\"":\""OPEN\"",\""details\"":{\""openCount\"":0,\""mergedCount\"":0,\""declinedCount\"":0,\""total\"":0},\""open\"":true},\""byInstanceType\"":{}},\""build\"":{\""overall\"":{\""count\"":0,\""lastUpdated\"":null,\""failedBuildCount\"":0,\""successfulBuildCount\"":0,\""unknownBuildCount\"":0},\""byInstanceType\"":{}},\""review\"":{\""overall\"":{\""count\"":0,\""lastUpdated\"":null,\""stateCount\"":0,\""state\"":null,\""dueDate\"":null,\""overDue\"":false,\""completed\"":false},\""byInstanceType\"":{}},\""deployment-environment\"":{\""overall\"":{\""count\"":0,\""lastUpdated\"":null,\""topEnvironments\"":[],\""showProjects\"":false,\""successfulCount\"":0},\""byInstanceType\"":{}},\""repository\"":{\""overall\"":{\""count\"":0,\""lastUpdated\"":null},\""byInstanceType\"":{}},\""branch\"":{\""overall\"":{\""count\"":0,\""lastUpdated\"":null},\""byInstanceType\"":{}}}},\""isStale\"":true}}""}}]}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}