package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)G[104,401,404,501,505]`)
var str = `G104
G105
G401
G402
G404
G501
G505
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}