re = /(?<=[?&])([^=]+)=\K[^=]+(?=&|$)/
str = 'http://www.nearbynursinghomes.com/innerpage.php?state=CA&city=RIVERSIDE&shop=ALTA VISTA HEALTHCARE & WELLNESS CENTRE'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end