$re = '/a(\S{7,50})?b/m';
$str = 'a1234567b';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);