# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?m)(?<_KEY_1>\w+[^:]+?)\s+:\s(?<_VAL_1>[^\r\n]+)$"
test_str = (" Name : Mobile Broadband Connection\n"
" Description : Orange Mobile Broadband Device - Ice Cold with pulp Mmmmmmm\n"
" GUID : {12AE12A1-12CD-1BC1-A012-C1A1234CBE12}\n"
" Physical Address : 00:a0:c6:00:00:00\n"
" State : Connected\n"
" Device type : Mobile Broadband device is embedded in the system\n"
" Cellular class : CDMA\n"
" Device Id : T1231230088BD5E8\n"
" Manufacturer : Orange\n"
" Model : Orange 2000\n"
" Firmware Version : 4.1.2\n"
" Provider Name : Buttercup Wireless\n"
" Roaming : Not roaming\n"
" Signal : 48%\n"
" Device : 98")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.