#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*\d+\s*:\s*(?:o?|(oo+?)\1+)$"
Local $sString = " 0 : " & @CRLF & _
" 1 : o" & @CRLF & _
" 2 : oo" & @CRLF & _
" 3 : ooo" & @CRLF & _
" 4 : oooo" & @CRLF & _
" 5 : ooooo" & @CRLF & _
" 6 : oooooo" & @CRLF & _
" 7 : ooooooo" & @CRLF & _
" 8 : oooooooo" & @CRLF & _
" 9 : ooooooooo" & @CRLF & _
"10 : oooooooooo" & @CRLF & _
"11 : ooooooooooo" & @CRLF & _
"12 : oooooooooooo" & @CRLF & _
"13 : ooooooooooooo" & @CRLF & _
"14 : oooooooooooooo" & @CRLF & _
"15 : ooooooooooooooo" & @CRLF & _
"16 : oooooooooooooooo" & @CRLF & _
"17 : ooooooooooooooooo" & @CRLF & _
"18 : oooooooooooooooooo" & @CRLF & _
"19 : ooooooooooooooooooo" & @CRLF & _
"20 : oooooooooooooooooooo" & @CRLF & _
"21 : ooooooooooooooooooooo" & @CRLF & _
"22 : oooooooooooooooooooooo" & @CRLF & _
"23 : ooooooooooooooooooooooo" & @CRLF & _
"24 : oooooooooooooooooooooooo" & @CRLF & _
"25 : ooooooooooooooooooooooooo" & @CRLF & _
"26 : oooooooooooooooooooooooooo" & @CRLF & _
"27 : ooooooooooooooooooooooooooo" & @CRLF & _
"28 : oooooooooooooooooooooooooooo" & @CRLF & _
"29 : ooooooooooooooooooooooooooooo" & @CRLF & _
"30 : oooooooooooooooooooooooooooooo" & @CRLF & _
"31 : ooooooooooooooooooooooooooooooo" & @CRLF & _
"32 : oooooooooooooooooooooooooooooooo" & @CRLF & _
"33 : ooooooooooooooooooooooooooooooooo" & @CRLF & _
"34 : oooooooooooooooooooooooooooooooooo" & @CRLF & _
"35 : ooooooooooooooooooooooooooooooooooo" & @CRLF & _
"36 : oooooooooooooooooooooooooooooooooooo" & @CRLF & _
"37 : ooooooooooooooooooooooooooooooooooooo" & @CRLF & _
"38 : oooooooooooooooooooooooooooooooooooooo" & @CRLF & _
"39 : ooooooooooooooooooooooooooooooooooooooo" & @CRLF & _
"40 : oooooooooooooooooooooooooooooooooooooooo" & @CRLF & _
"41 : ooooooooooooooooooooooooooooooooooooooooo" & @CRLF & _
"42 : oooooooooooooooooooooooooooooooooooooooooo" & @CRLF & _
"43 : ooooooooooooooooooooooooooooooooooooooooooo" & @CRLF & _
"44 : oooooooooooooooooooooooooooooooooooooooooooo" & @CRLF & _
"45 : ooooooooooooooooooooooooooooooooooooooooooooo" & @CRLF & _
"46 : oooooooooooooooooooooooooooooooooooooooooooooo" & @CRLF & _
"47 : ooooooooooooooooooooooooooooooooooooooooooooooo" & @CRLF & _
"48 : oooooooooooooooooooooooooooooooooooooooooooooooo" & @CRLF & _
"49 : ooooooooooooooooooooooooooooooooooooooooooooooooo" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")