$re = '/(\w)\1+(*SKIP)(*F)|(\w+?)\2+/';
$str = 'Hi hi missing u lollol hahahahalol sillybilly haaaaa!';
$subst = "\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;