package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:(?<x>[0-9A-Fa-f]{2}):){5}(?&x)`)
var str = `00:18:12:c1:5a:5a`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}