$re = '/(?:([0-9A-Fa-f]{2}):){5}(?1)/m';
$str = '00:18:12:c1:5a:5a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);