#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\n(\d{1,3}(?: \d{3})+)(,\d{2})? {,2}[а-яА-Я,. ()]+\b(с|\d{2} копеек\)?, в)"
Local $sString = "3 322 559,32 руб. без НДС." & @CRLF & _
" 598 060,67 руб. НДС " & @CRLF & _
"3 920 619,99руб. с НДС." & @CRLF & _
"" & @CRLF & _
"5 026 813,65 руб. без НДС;" & @CRLF & _
" 904 826,46 руб. НДС (18%);" & @CRLF & _
"5 931 640,11 руб. с НДС" & @CRLF & _
"" & @CRLF & _
"Лот 1." & @CRLF & _
"4 837 251,02 руб. без НДС;" & @CRLF & _
"870 050,18 руб. НДС (18%);" & @CRLF & _
"5 707 956,20 руб. с НДС" & @CRLF & _
"" & @CRLF & _
"Лот 2." & @CRLF & _
"75 290,87 руб. без НДС;" & @CRLF & _
"13 552,36 руб. НДС (18%);" & @CRLF & _
"88 843,23 руб. с НДС" & @CRLF & _
"" & @CRLF & _
"ИТОГО:" & @CRLF & _
"4 912 541,89 руб. без НДС" & @CRLF & _
"884 257,54 руб. НДС (18%);" & @CRLF & _
"5 796 799,43 руб. с НДС" & @CRLF & _
"" & @CRLF & _
"1 307 856 (Один миллион триста семь тысяч восемьсот пятьдесят шесть) рублей 67 копеек, в т.ч. НДС." & @CRLF & _
"1 214 490 (Один миллион двести четырнадцать тысяч четыреста девяносто) рублей 67 копеек, без учета НДС." & @CRLF & _
"" & @CRLF & _
"307 272,00 рублей (Триста семь тысяч двести семьдесят два рубля 00 копеек), включая НДС. " & @CRLF & _
"260 400,00 рублей (Двести шестьдесят тысяч четыреста рублей 00 копеек), без учета НДС." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")