$re = '/\bfile\b[^/]*(?:/[^/\n]+)*/([^/\n]+\.\w+)/m';
$str = 'Line number 12983: Importing file /user/path/abcde.csv.
linenumber 1234: events were written to file ‘/usr/path/filename.GMF’ (threshold 0)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);