use strict;
my $str = 'Feb 19 00:05:04 smtp2 sm-mta[28608]: l1J652ZW028608: from=<dsbugeyed@example.org>, size=15433, class=0, nrcpts=1, msgid=<001001c75437$5633fa90$06aeb57c@samsungtkb30u2>, proto=SMTP, daemon=MTA, relay=[58.78.156.175]';
my $regex = qr/sm-mta\[.*\]:\s(?<qid>.*?):/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}